flex docking trouble

Message boards : Number crunching : flex docking trouble

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 747 - Posted: 11 Jul 2009, 16:40:00 UTC
Last modified: 11 Jul 2009, 16:40:46 UTC

This is where I am on the flex docking. Two questions:
1) Why does it report Bad file descriptor when it is run by the wrapper?
2) Why does the second time it reports Bad file descriptor it terminates? That is it terminates when preping the flexible receptor.

wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities
24/prepare_flexreceptor4.py" -l ligand.pdbqt -r receptor.pdbqt -g receptor_rigid
.pdbqt -x receptor_flex.pdbqt -s ILE95)
close failed: [Errno 9] Bad file descriptor
app exit status: 0x2
called boinc_finish

c:\ProgramData\BOINC\slots\0>Python25\python.exe MGLToolsPckgs\AutoDockTools\Uti
lities24\prepare_flexdocking4.py  -l ligand.pdbqt -r receptor.pdbqt -g receptor_
rigid.pdbqt -x receptor_flex.pdbqt -s ILE95

c:\ProgramData\BOINC\slots\0>



As you can see, when I run this in the command line it reports no such errors!!!
ID: 747 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 748 - Posted: 11 Jul 2009, 16:42:55 UTC - in response to Message 747.  
Last modified: 11 Jul 2009, 16:45:24 UTC

i have no clue, but current run, flex_4_ models are all erroring out, i'm suspending those and letting computer try flex_3- and rigid wu's...


7/11/2009 12:42:16 PM DrugDiscovery [error] Can't rename output file flex_4_23928_ChemDiv_3710-0012_1247326994843124498_2_0 to projects/boinc.drugdiscoveryathome.com/flex_4_23928_ChemDiv_3710-0012_1247326994843124498_2_0: Error 2
7/11/2009 12:42:17 PM DrugDiscovery Computation for task flex_4_23928_ChemDiv_3710-0012_1247326994843124498_2 finished


flex_3- wu's same result... error... going to try rigid
ID: 748 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 749 - Posted: 11 Jul 2009, 16:45:26 UTC - in response to Message 748.  

well I will discuss with our friends on the BOINC IRC...got a few hours before I go to an early Bastille day party. It will have to do for my birthday cellebration since its hard to get people together on Tuesday.

Jack
ID: 749 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 750 - Posted: 11 Jul 2009, 18:12:11 UTC - in response to Message 749.  

I modified a job file running stand-alone and uploaded it. Seems to do flexible ok. But only one residue. What happens when we add another? We will see.
ID: 750 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 753 - Posted: 11 Jul 2009, 22:14:33 UTC - in response to Message 750.  

i just got some more task and still get errors.
Tim Turner
Public Relations Admin
Secunia PSI: http://secunia.com/vulnerability_scanning/personal/
If you need help via voice or Convo; PM me and i will give you details on where i will be; Teamspeak, Yahoo Messenger, or Skype.
ID: 753 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 755 - Posted: 12 Jul 2009, 5:29:16 UTC - in response to Message 753.  

how about ones with this prefix?
flex_TYR52_LEU33_GLN2_
ID: 755 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 758 - Posted: 12 Jul 2009, 14:26:44 UTC - in response to Message 755.  
Last modified: 12 Jul 2009, 14:35:51 UTC

jack i'm trying some of those P10_tyr wu's right now, and from the looks of the first one, they seem to be ok...

will update in a few minutes once these 4 have run.

Edit: those P10-tyr5 wu's are running fine...

work unit file..

<core_client_version>6.6.28</core_client_version>
<![CDATA[
<stderr_txt>
wrapper: starting
wrapper: running ../../projects/boinc.drugdiscoveryathome.com/unzip_1.011_windows_intelx86.exe (-qq -o "./MGLTools*.zip" -d ".")
wrapper: running 7za.exe (e ligand.mol2.7z)
wrapper: running ./Python25/python.exe (make_sitecustomize.py ".")
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/Support/sitecustomize.py")
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities24/prepare_ligand4.py" -l ligand.mol2 -o ligand.pdbqt)
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities24/prepare_receptor4.py" -U nphs_lps_waters -r receptor.pdb -o receptor.pdbqt)
close failed: [Errno 9] Bad file descriptor
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities24/prepare_flexreceptor4.py" -r receptor.pdbqt -g receptor_rigid.pdbqt -x receptor_flex.pdbqt -s TYR52_LEU33_GLN56)
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities24/prepare_gpf4.py" -l ligand.pdbqt -r receptor.pdbqt -p custom_parameter_file=1 -p parameter_file=AD4_parameters.dat)
wrapper: running ./Python25/python.exe ("./MGLToolsPckgs/AutoDockTools/Utilities24/prepare_dpf4.py" -l ligand.pdbqt -r receptor.pdbqt -p compute_unbound_extended_flag=0 -p ga_run=1)
wrapper: running ../../projects/boinc.drugdiscoveryathome.com/autogrid_1.011_windows_intelx86.exe (-p receptor.gpf -l out.glg)
wrapper: running ../../projects/boinc.drugdiscoveryathome.com/autodock_1.011_windows_intelx86.exe (-p ligand_receptor.dpf -l out.dlg)
wrapper: running 7za.exe (a out.7z out.dlg)
called boinc_finish

</stderr_txt>
]]>
ID: 758 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 761 - Posted: 13 Jul 2009, 2:43:28 UTC - in response to Message 760.  
Last modified: 13 Jul 2009, 2:43:49 UTC

no problems so far... good work/job jack...
ID: 761 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 762 - Posted: 13 Jul 2009, 3:22:39 UTC - in response to Message 761.  

hopefully we can cruise through this queue in the next few days. Currently we are only using 1 genetic algorithm itteration. Lets see how long it drags...eventually we will need to do this set again with at least 10 ga_runs and perhaps several more attempts to for quality assurance. I'm worried we will need more hosts.
ID: 762 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 764 - Posted: 13 Jul 2009, 13:48:47 UTC - in response to Message 762.  
Last modified: 13 Jul 2009, 13:51:04 UTC

i've only got 3 of my 4 cores running drugd. right now... i have a cpdn wu in progress but i think i'll stop it.

i'll also add one of my p4 pc to the dd list...
ID: 764 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile [AF>Libristes] Dudumomo

Send message
Joined: 1 May 09
Posts: 63
Credit: 39,940
RAC: 0
Message 765 - Posted: 13 Jul 2009, 15:57:47 UTC - in response to Message 764.  

So far so good with the new batch !
But it's difficult for me to get some cache...Only 2WU/time.
Is it possible to increase this ?
I'm not connected to Internet 24h/24

If you can increase the limit, I will attach 2 others computers. (Amd x2 6000+ and P4 3.2HT on Linux)

Anyway, I will contact some members of my team.

Good job !
ID: 765 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Ageless
Avatar

Send message
Joined: 11 Apr 09
Posts: 172
Credit: 7,631
RAC: 0
Message 766 - Posted: 13 Jul 2009, 16:30:50 UTC - in response to Message 765.  

Go to your computing preferences and adjust the amount of days work in "Maintain enough work for an additional x.xx days".

Don't overdo it.
Jord

'Cause you seem like an orchard of mines, Just take one step at a time.
ID: 766 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile [AF>Libristes] Dudumomo

Send message
Joined: 1 May 09
Posts: 63
Credit: 39,940
RAC: 0
Message 767 - Posted: 13 Jul 2009, 16:57:22 UTC - in response to Message 766.  

Sorry for my poor explaination, but I mean that I receive only 2WU per update

Mon 13 Jul 2009 17:52:12 CEST|Virtual Prairie|Scheduler request completed: got 2 new tasks

Always the same thing. And I have to wait the next update to receive some (Or to do it manually) but because I'm using 56k connection, it takes times to accomplish an update, and because the WU last 1min, it's difficult to have any sufficient cache to crunch only on DD without my connection opened.

You know what I mean now ?

Thanks Jack !
ID: 767 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 768 - Posted: 13 Jul 2009, 18:29:50 UTC - in response to Message 767.  

This page describes what you can do with the project configurations for scheduling
http://boinc.berkeley.edu/trac/wiki/ProjectOptions

<max_wus_in_progress> N </max_wus_in_progress>


I set this to 500 how does that sound???
ID: 768 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile [AF>Libristes] Dudumomo

Send message
Joined: 1 May 09
Posts: 63
Credit: 39,940
RAC: 0
Message 769 - Posted: 13 Jul 2009, 19:02:18 UTC - in response to Message 768.  

If I have understood well, this setting is for the maximum number of task in progress (Running + Cache)
500WUs with my computer (T9400 2.53Ghz on Gentoo 64) is like 500min or 600min (1min per task) divided by 2 (Dual core) = 250 - 300 min of cache....5h only.

May be it's a bit too low. Especially for Quad or Octo (In fact, it's because it's very quick to calculate one WU).

Anyway, this was not my problem yet, it is not the maximum WU, sent to the host.
For example, with Wanless WEP, the max is 12 WU per update. With NQueens....I don't know, it was always a big amount (50 - 60)

So, I will try to find as well on your link the solution.
ID: 769 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 770 - Posted: 13 Jul 2009, 20:05:33 UTC - in response to Message 769.  

it's just fine for me... no problems getting work and i have my cache at 1 day so boinc doesn't get loaded up with wu's... they take 5-7 mins on my quad and 14 mins on the p4's i have....
ID: 770 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile [AF>Libristes] Dudumomo

Send message
Joined: 1 May 09
Posts: 63
Credit: 39,940
RAC: 0
Message 771 - Posted: 13 Jul 2009, 20:12:51 UTC - in response to Message 770.  
Last modified: 13 Jul 2009, 20:26:39 UTC

Zpm, do you get more than 2WU per time if you update the project ?

Edit : Damn, with my P4 I just got 16 new tasks...

Hmm... I have to retry with my laptop.
ID: 771 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 772 - Posted: 13 Jul 2009, 20:21:02 UTC - in response to Message 771.  
Last modified: 13 Jul 2009, 20:26:30 UTC

it depends on how many it reports .... boinc reports 10 task done, it gives me 8, if i report 2 task, it gives me 1 task.... as long as you have like 45 in your cache it should be a problem unless your returning task as fast as you get them...


what is your work cache set too in the manager?

oh, in my ready to start zone i have 3 cpdn models, 14 rossetta, and about 300 dd wu's.... i have cpdn and rossetta suspended..
ID: 772 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile [AF>Libristes] Dudumomo

Send message
Joined: 1 May 09
Posts: 63
Credit: 39,940
RAC: 0
Message 773 - Posted: 13 Jul 2009, 21:09:32 UTC - in response to Message 772.  

hmmm... in additional work buffer I have 1.20
I have VTU@home suspended

Mon 13 Jul 2009 22:04:45 CEST|DrugDiscovery|Sending scheduler request: To fetch work. Requesting 222418 seconds of work, reporting 23 completed tasks

Mon 13 Jul 2009 22:06:02 CEST|DrugDiscovery|Scheduler request completed: got 1 new tasks

It seems to be only my problem...sorry about that !
ID: 773 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 774 - Posted: 13 Jul 2009, 21:34:30 UTC - in response to Message 773.  
Last modified: 13 Jul 2009, 21:36:43 UTC

what is that cest thing????

are you running 6.4.5 version????
<core_client_version>6.4.5</core_client_version>
as i see it on your wu's....

i think that if you update to the latest version for linux, this problem should go away as their have been refinements in the scheduler program.
ID: 774 · Rating: 0 · rate: Rate + / Rate - Report as offensive
1 · 2 · Next

Message boards : Number crunching : flex docking trouble


©2017 All rights reserved | Design by Digital BioPharm Ltd