Progress bar

Message boards : Number crunching : Progress bar

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1918 - Posted: 5 Dec 2009, 17:48:05 UTC

Can you report whether the progress bar on mdrun is working? It may have been disabled when we removed the verbose flag from our command line arguements.
ID: 1918 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 1919 - Posted: 5 Dec 2009, 19:27:29 UTC - in response to Message 1918.  

doesn't seem to be working on my quad core.
Tim Turner
Public Relations Admin
Secunia PSI: http://secunia.com/vulnerability_scanning/personal/
If you need help via voice or Convo; PM me and i will give you details on where i will be; Teamspeak, Yahoo Messenger, or Skype.
ID: 1919 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Van Fanel
Avatar

Send message
Joined: 16 Sep 09
Posts: 17
Credit: 103,550
RAC: 0
Message 1924 - Posted: 6 Dec 2009, 12:53:42 UTC

Not working with version 7.28 in a Win32bit machine.
ID: 1924 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Erkan Yilmaz
Avatar

Send message
Joined: 31 Oct 09
Posts: 69
Credit: 108,502
RAC: 15
Message 1926 - Posted: 6 Dec 2009, 14:44:02 UTC
Last modified: 6 Dec 2009, 15:32:35 UTC

progress bar not working :-(

mdrun v7.28
windows 64bit RC
boinc 6.10.17
Standing on the shoulders of giants
ID: 1926 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1935 - Posted: 9 Dec 2009, 15:03:39 UTC - in response to Message 1926.  

let me know if the progress bar is working now. Regardless to version, it won't work if I remove the -v argument from the workunits.
ID: 1935 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Van Fanel
Avatar

Send message
Joined: 16 Sep 09
Posts: 17
Credit: 103,550
RAC: 0
Message 1941 - Posted: 9 Dec 2009, 18:16:51 UTC

Ubuntu 64bit machine.
Application: mdrun 2.09.

The progress bar is crazy!
It shows 666.667%, 2000.000% (two thousand per cent), 2666.667%, etc. all the way up to 9000.000%. Almost in the end of the WU, it goes back to 'normality' showing 99%, and finally 100%. It doesn't go beyond 100% any more as it used to.

Someone forgot to divide something by a factor of 100, no? ;-)
ID: 1941 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1942 - Posted: 9 Dec 2009, 19:23:59 UTC - in response to Message 1941.  

I thought I was giving this project 120%!
ID: 1942 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Tim Turner
Avatar

Send message
Joined: 1 May 09
Posts: 570
Credit: 184,322
RAC: 0
Message 1948 - Posted: 10 Dec 2009, 17:16:23 UTC - in response to Message 1942.  

7.31 20 minutes still going and no progress update.
Tim Turner
Public Relations Admin
Secunia PSI: http://secunia.com/vulnerability_scanning/personal/
If you need help via voice or Convo; PM me and i will give you details on where i will be; Teamspeak, Yahoo Messenger, or Skype.
ID: 1948 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1949 - Posted: 10 Dec 2009, 17:49:17 UTC - in response to Message 1948.  

I took off the verbose flag. I restored it, now lets see if workunits fail again.
ID: 1949 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jaxis
Avatar

Send message
Joined: 16 Nov 09
Posts: 11
Credit: 75,686
RAC: 0
Message 1957 - Posted: 12 Dec 2009, 3:15:28 UTC

Re:mdrun beta test 7.04

I have A LOT of these and more downloading as I speak. Four have been running for over an hour and a half with no progress. Do I abort?
ID: 1957 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jaxis
Avatar

Send message
Joined: 16 Nov 09
Posts: 11
Credit: 75,686
RAC: 0
Message 1958 - Posted: 12 Dec 2009, 7:05:15 UTC

Re: mdrun beta test 7.04

14 wu's sent to me 12 Dec 2009 0:41:06 UTC
But the Time reported or deadline is 15 Nov 2009 6:00:00 UTC.
Perhaps this is my problem as to why they keep running without completing?

I hate to abort anything without permission. A couple of wu's have run for over two hours now.











ID: 1958 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Erkan Yilmaz
Avatar

Send message
Joined: 31 Oct 09
Posts: 69
Credit: 108,502
RAC: 15
Message 1959 - Posted: 12 Dec 2009, 10:00:34 UTC
Last modified: 12 Dec 2009, 10:05:42 UTC

about the progress bar:

Behaviour now is:
still stays at 0%
and then at end jumps to 97.959% and then WU finished immediately

could have been also like this earlier, since I only just now watched the WU operate

app: mdrun beta test v7.07
OS: win7 64 RC
just finished some WUs with outcome Success :-)
Standing on the shoulders of giants
ID: 1959 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Erkan Yilmaz
Avatar

Send message
Joined: 31 Oct 09
Posts: 69
Credit: 108,502
RAC: 15
Message 1960 - Posted: 12 Dec 2009, 10:46:09 UTC - in response to Message 1958.  

Hello Jaxis,

as I see Jack canceled same app on
win7 32bit, boinc 6.10.18

As I see you are getting also higher version number WUs, so it doesn't hurt to let these 14 still there, until Jack says something.

for all: these are the 14 WUs


Re: mdrun beta test 7.04

14 wu's sent to me 12 Dec 2009 0:41:06 UTC
But the Time reported or deadline is 15 Nov 2009 6:00:00 UTC.
Perhaps this is my problem as to why they keep running without completing?

I hate to abort anything without permission. A couple of wu's have run for over two hours now.













Standing on the shoulders of giants
ID: 1960 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jaxis
Avatar

Send message
Joined: 16 Nov 09
Posts: 11
Credit: 75,686
RAC: 0
Message 1961 - Posted: 12 Dec 2009, 14:52:17 UTC

Thanks for advice Erkan!
ID: 1961 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1963 - Posted: 12 Dec 2009, 18:20:38 UTC - in response to Message 1961.  

I spent the last several days trying to figure out the progress bar issues. Here I will share the actual code modification that was driving me crazy and I still don't understand it but now I seem to have good workunits.

When we call the verbose flag, it runs a function called print_time. This function performs several different output opperations depending on certain conditions. The else condition is to print the remaining time. Under some

this is what my code modification looked like initially, I reported the fraction complete to stderr and a progress file

    else     
      fprintf(out,", remaining runtime: %5d s          ",(int)dt);
      fprintf(stderr, ",Fraction Complete: %g\n",(step - ir->init_step) / (float) ir->nsteps);

      f = fopen("progress.txt", "w");
      if (!f) return;
      fprintf(f, "%g", (step - ir->init_step) / (float) ir->nsteps);
	  fclose(f);


Since this caused frequent errors I have debugged this quite a bit. Here is the new code. I took out the reporting to stderr. So it won't say the fraction complete on the error reports.

    else     
      fprintf(out,", remaining runtime: %5d s          ",(int)dt);

      f = fopen("progress.txt", "w");
      if (!f) return;
      fprintf(f, "%g", (step - ir->init_step) / (float) ir->nsteps);
	  fclose(f);



ID: 1963 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Van Fanel
Avatar

Send message
Joined: 16 Sep 09
Posts: 17
Credit: 103,550
RAC: 0
Message 1965 - Posted: 12 Dec 2009, 19:40:46 UTC

Ubuntu 64bit
mdrun 2.10

Same thing as with the previous app version... No change on my end.
ID: 1965 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1967 - Posted: 13 Dec 2009, 5:29:29 UTC - in response to Message 1965.  

Ok please tell me if there is any improvement. I just made it using 64-bit suse
ID: 1967 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Van Fanel
Avatar

Send message
Joined: 16 Sep 09
Posts: 17
Credit: 103,550
RAC: 0
Message 1971 - Posted: 14 Dec 2009, 13:29:07 UTC
Last modified: 14 Dec 2009, 13:30:36 UTC

Machine: Ubuntu 64bit
Application: mdrun 2.13
WU: nsteps_50000_int_0_-_10000_...

The progress bar seems to be working fine now.


(The same can not be said for autodock WUs - it still goes to 108% near the end, but the rest of the time it looks fine)
ID: 1971 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Jack Shultz
Avatar

Send message
Joined: 10 Apr 09
Posts: 503
Credit: 120,150
RAC: 0
Message 1973 - Posted: 14 Dec 2009, 19:24:05 UTC - in response to Message 1971.  

Is the problem isolated to Melmack?
ID: 1973 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Van Fanel
Avatar

Send message
Joined: 16 Sep 09
Posts: 17
Credit: 103,550
RAC: 0
Message 1978 - Posted: 15 Dec 2009, 17:32:06 UTC - in response to Message 1973.  

Is the problem isolated to Melmack?

It wasn't. I have another machine with Windows XP 32bit and autodock WUs would also reach 108% towards their end, same as in Linux 64bit. I haven't seen an autodock in some days, so I don't know if the problem has been fixed or not.
ID: 1978 · Rating: 0 · rate: Rate + / Rate - Report as offensive
1 · 2 · Next

Message boards : Number crunching : Progress bar


©2017 All rights reserved | Design by Digital BioPharm Ltd